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EU Declaration of Conformity 
 
This is to certify that the accompanying product, identified with the CE mark, 
complies with requirements of the Electromagnetic Compatibility Directives. 
 
 
Model name: OBP Series – USB Version 
Certificate No:   9412325060 
Year CE mark affixed:  2014 
Type of equipment:  Optical position and power measurement system, 

analog and USB interface. 
 

 
Has been tested and was found to comply with the requirements of: 
 
• EN 55022 Class B:  “Information technology equipment –  
     Radio disturbance characteristics –  
     Limits and methods of measurement” (2010). 
 

 
 

• IEC 61000-3-3: “Electromagnetic Compatibility (EMC)”, 
    Part 3: “Limits”; 

Section 3. “Limitation of voltage changes, voltage fluctuations 
and flicker in public low-voltage supply systems, for 
equipment with rated current < 16 A per phase and not 
subjected to conditional connection” Ed.2 (2008) 

 
 
• EN 55024: “Information technology equipment –  
   Immunity characteristics – 
   Limits and methods of measurement” (2010). 

  

The undersigned hereby declare that the equipment specified above conforms to 
the above directive(s) and standard(s).  
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RoHS Declaration of Conformity 
 
We hereby certify that the following product: OBP Series – USB Version meets the 
requirements of the European Directive 2002/95/EC (RoHS) on the restriction of the use of 
certain hazardous substances in electrical and electronic equipment. 
 
This product does not contain any of the six (6) restricted substances as stated below, which 
are: 
 

- Cadmium (Cd) 
- Chromium VI (Cr + 6) 
- Polybrominated biphenyl (PBB) 
- Polybrominated biphenyl ether (PBDE) 
- Lead (Pb) 
- Mercury (Hg) 

 

 

 

 

 

 

  

  

Alain Danielo    Jay Jeong 
VP European Operations  Product Manager 
Zone Industrielle   1791 Deere Avenue 

         45340 Beaune-la-Rolande, France Irvine, Ca. USA 
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Warranty 
 
Newport Corporation warrants that this product will be free from defects in 
material and workmanship and will comply with Newport’s published specifications 
at the time of sale for a period of one year from date of shipment. If found to be 
defective during the warranty period, the product will either be repaired or 
replaced at Newport’s option. 
To exercise this warranty, write or call your Newport office or representative, or 
contact Newport headquarters in Irvine, California. You will be given prompt 
assistance and return instructions. Send the product, freight prepaid, to the 
indicated service facility. Repairs will be made and the instrument returned freight 
prepaid. Repaired products are warranted for the reminder of the original warranty 
period or 90 days, whichever first occurs. 
 
Limitation of Warranty 
 
The above warranties do not apply to products which have been repaired or 
modified without Newport’s written approval, or products subjected to unusual 
physical, thermal or electrical stress, improper installation, misuse, abuse, 
accident or negligence in use, storage, transportation or handling. This warranty 
also does not apply to fuses, batteries, or damage from battery leakage. 
 
THIS WARRANTY IS IN LIEU OF ALL OTHER WARRANTIES, EXPRESSED OR 
IMPLIED, INCLUDING ANY IMPLIED WARRANTY OF MERCHNATABILITY OR 
FITNESS FOR A PARTICULAR USE. NEWPORT CORPORATION SHALL NOT 
BE LIABLE FOR ANY INDIRECT, SPECIAL, OR CONSEQUENTIAL DAMAGES 
RESULTING FROM THE PURCHASE OR USE OF ITS PRODUCTS. 
First printing 2003  
 2003 by Newport Corporation, Irvine, CA. All rights reserved. No part of this 
manual may be reproduced or copied without the prior written approval of 
Newport Corporation. 
This manual has been provided for information only and product specifications are 
subject to change without notice. Any change will be reflected in future printings. 
 
 
 
Newport Corporation 
1791 Deere Avenue 
Irvine, CA 92606 
USA 
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Confidentiality & Proprietary Rights 
Reservation of Title: 
The Newport programs and all materials furnished or produced in connection with 
them (“Related Materials”) contain trade secrets of Newport and are for use only in the 
manner expressly permitted. Newport claims and reserves all rights and benefits 
afforded under law in the Programs provided by Newport Corporation. 

Newport shall retain full ownership of Intellectual Property Rights in and to all 
development, process, align or assembly technologies developed and other derivative 
work than may be developed by Newport. Customer shall not challenge, or cause any 
third party to challenge the rights of Newport. 

Preservation of Secrecy and Confidentiality and Restrictions to Access: 

Customer shall protect the Newport Programs and Related Materials as trade secrets 
of Newport, and shall devote its best effects to ensure that all its personnel protect the 
Newport Programs as trade secrets of Newport Corporation. Customer shall not at any 
time disclose Newport’s trade secrets to any other person, firm, organization, or 
employee than does not need (consistent with Customer’s right of use hereunder) to 
obtain access to the Newport Programs and Related Materials. These restrictions shall 
not apply to information (1) generally known to the public or obtainable from public 
source; (2) readily apparent from the keyboard operation, visual display, or output 
reports of the Programs; (3) previously in the possession of Customer or subsequently 
developed or acquired without reliance on the Newport Programs; or (4) approved by 
Newport for release without restriction. 

Service Information 

This section contains information regarding factory service for the source. The user 
should not attempt any maintenance or service of the system or optional equipment 
beyond the procedures outlined in this manual. Any problem that cannot be resolved 
should be referred to Newport Corporation. 
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Technical Support Contacts 
 
North America Europe 

Newport Corporation Service Dept. Newport/Mcro-Controle S.A. 
1791 Deere Ave. Zone Industrielle 
Irvine, CA 92606  45340 Beaune la Rolande.France 
Telephone: (949) 253-1694 Telephone: (33) 02 38 40 51 49 

Telephone: (800) 222-6440 x31694 

 

Newport Opto-Electronics Technologies 

(Wuxi) Co., Ltd. 

理波光电科技（无锡）有限公司 
Lot J3-8, Wuxi Export Processing Zone, New District 

Jiangsu, China 

中国江苏省无锡新区出口加工区J3地块8号厂房 
Telephone: +86-510-8113 5000 

Fax: +86-510-8526 9050 

 

Newport Corporation Calling Procedure 

If there are any defects in material or workmanship or a failure to meet specifications, 
promptly notify Newport’s Returns Department by calling 1-800-222-6440 or by visiting 
our website at www.newport.com/returns within the warranty period to obtain a Return 
Material Authorization Number (RMA#). Return the product to Newport Corporation, 
freight prepaid, clearly marked with the RMA# and we will repair or replace it at our 
discretion. Newport is not responsible for damage occurring in transit and is not 
obligated to accept products returned without an RMA#. 

E-mail: rma.service@newport.com 

When calling Newport Corporation, please provide the customer care representative 
with the following information: 

• Your Contact Information 
• Serial number or original order number 
• Description of problem (i.e., hardware or software) 

 
To help our Technical Support Representative diagnose your problem, please note the 

following conditions: 
• Is the system used for manufacturing or research and development? 
• What was the state of the system right before the problem? 
• Have you seen this problem before? If so, how often? 
• Can the system continue to operate with this problem? Or is the system non-

operational? 
• Can you identify anything that was different before this problem occurred? 

 
 
 

http://www.newport.com/returns
mailto:rma.service@newport.com
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1.0  
Introduction 
 
Welcome to the OBP Series - USB Version! 
 
The OBP Series - USB Version is designed to perform simultaneous measurements of 
Position and Power displacements of CW laser beams. 
 
This is a USB software driven device that resides in a user-provided host computer. It is a 
user-friendly system presenting both graphical and numerical information for intuitive 
interpretation of data. The menu-driven software is designed to be controlled by either a 
keyboard or a mouse. 
The OBP Series - USB device and software can be integrated into a variety of PC compatible 
computer platforms (Laptop computers, Notebooks, or host PC computers), running under a 
Windows 2000 / XP / Vista / 7 operating systems to meet a wide range of automated laser 
beam alignment applications both in the laboratory and in the field. 
 
 
 
The system consists of: 
 
w A manifold box which plugs into the USB device and has sockets for connection of sensor 
head and power supply 
 
w A measuring head composed of a Lateral Effect sensor (Position sensing) 
 
w A power supply 
 
w An operation Windows software package CD disk 
 
The Windows software provides an extensive range of graphical displays and analysis 
capabilities, where one can operate both the Position and Power measurements in parallel. 
 
While the Position sensing capability is activated the system provides a real-time display of 
position deviations, as well as data storage and temporal analysis.  
Relative measurements to any pre-defined point on the detector is also available.  
While the Position measurements are done, one can activate the Power measuring capability 
of the position-sensing detector. Additionally, one can activate the Plot or Chart functions, in 
order to observe strip-chart type plots of either Power versus Time, or XY Position versus 
Time, with auto scaling and saving capabilities. The Scope function enables presentation of 
real time oscilloscope type display of beam Position deviations (or Power fluctuations) versus 
Time. 
 
Help screens are available from every screen (context sensitive and enable branching to 
other topics via keywords). 
 
Setup screens are available via soft-button access from every presentation type. The system 
enables the user to configure its setup options & screens to suit a particular set of needs and 
save such configurations for future sessions (via Options function). 
 
When using position sensing detectors it is frequently necessary to use attenuating filters to 
prevent saturation of the sensor. For this reason, we may offer a neutral density filter or an 
interference filter mounted as options. Each filter comes with its responsivity file, so for each 
wavelength entered power readings will be accurate. This is done by activating Filter button. 
The system has a File handling capabilities, where data can be saved for later analysis. File 
can be printed or transmitted via RS232 link protocol to another PC computer. Additionally 
data can be transferred via TCP/IP protocol to another computer, or via Client Communication 
Program.  
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Each system composed of a USB device, manifold box, sensor head and software are a 
serialized and matched set. 
 
Main Features 

• Parallel modes of operation: analog and digital data 
• Built in high precision power supply 
• External trigger for synchronized data acquisition 
• Multiple device control via USB (up to 8 devices) 

• TCP/IP Communication protocol and remote control 
• ActiveX software for integration in customer’s application program 

 

Main Software Features 
• Real time display of Position and Power  
• Three operation modes for digital data: Display, Scope and Remote operation  
• Simultaneous presentations of Position, Power, Plot, Chart and Scope modes 
• Data streaming via RS232 
• Multiple systems operation 
• Direct data logging to Excel files 
• Scope Mode for saving and analyzing memory data (up to 4KHz) 

 
 
 
1.1 Copyright and manual notice 
 
This manual describes the operation of the OBP Series - USB Version system. 
Duma Optronics reserves the right to make changes to this manual and to the equipment 
described herein without notice. 
Duma Optronics has made considerable efforts to ensure that the information in this manual is 
accurate and complete, however will not be liable for any technical or editorial errors or 
omissions made herein or for any consequential damages of any nature resulting from the 
furnishing of this manual or operation of equipment in connection with this manual. 
 
 
1.2 Revision History 
 
Any new editions of this manual will incorporate all material updated since the previous edition. 
Update packages issued between editions contain replacement and/or additional pages to be 
appended to the current edition. A “README.TXT” file is provided during the installation and 
may contain additions or corrections to the manual or the help file. 
The manual printing date indicates its current edition. Updates and corrections to the current 
edition will be indicated:   
 
                          April 2004 – Revision 1.0 
  Dec 2004 – Revision 1.1 
  Sep 2006 – Revision 1.2 
  May 2007 – Revision 1.3 
  January 2008 – Revision 1.4 
  December 2008 – Revision 2.0 
  October 2014 – Revision 2.1 
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1.3 Precautions 
 
The OBP Series - USB Version is a precision instrument and in normal usage will provide 
years of trouble free operation. 
However, several precautions must be taken to ensure proper function of the device: 
 
w The instrument must not be subjected to physical abuse. If either the manifold box or 
detector head are dropped they might be damaged. 
 
w Temperature and moisture extremes can also damage the instruments. Make sure there is 
  adequate ventilation for the host computer. 
 
w Make sure you have a backup copy for the system diskette, and that the software CD is 
protected from long term, direct exposure to sunlight and heat. 
 
w When not in use, keep a cap over the sensor heads to prevent dust from accumulating on 
the sensor. Dust, scratches and other types of contamination will degrade the accuracy of   
the system. 
 

 FThese instruments are usually used with laser sources. The operator should observe all 
laser safety procedures and precautions when operating these devices. In particular it should 
be noted that a portion of the laser beam incident on the sensors will be reflected. This can be 
hazardous and the operator should beware of both specular and diffuse reflections. The 
operator should exercise special care when working with invisible laser radiation.  
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2.0  
Specifications              
 
This system includes (Qty of 1 each, unless specified): 
 
   l  Manifold box  
      Plugs into the USB device via a USB 2.0 cable (1.8m long) connected to it. 
      Has sockets for 2 x 9 pin connectors, as follows: 
     
     A male connector for sensor head, a female connector for power supply, 
     Also has an RCA female connector for trigger input.      
       
      Has 2 x Led lamps, which light-up, as follows: 
     A Red light when the computer power is On 
     A Green light when the USB device is being connected to the USB port  
     Label: On bottom of manifold box. 
 
 
 
l  Detector Head 

Lateral Effect detector assembled to housing and cable. 
.  Label: On back of detector head. 
 
 
l  Power supply 
 
 
l      Installation software 
      One CD disk for Windows 2000 / XP / Vista / 7. 
     Software version: 2.0x 
 
 
l Certificate of test, signed and tested by test technician. 
 
 
l     User Manual (on CD disk) 
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General 
 
Photodetector (Default)           9*9mm dual axis silicon Lateral Effect 
                                                4*4mm dual axis silicon Later Effect optional 
    
Usable beam size range         50 µm < diameter < 8 mm   for 9*9mm version            
                                                 50 µm < diameter < 3 mm   for 4*4mm version                                                   
 
Position resolution  Better than ± 1µm typical      for 9*9mm version 
             Better than ± 0.5µm typical   for 4*4mm version 
 
Position accuracy                   ±15 µm over 8mm diameter using HeNe beam of 0.8mm 

                      
Calibrated spectral range       350 - 1100 nm 
 
Power Input range (*)             High Amplification module : 1µW - 250µW 
             Low Amplification module : 10µW - 2500µW  
 
Power accuracy (*)                 ±5% 
 
Power Supply Voltage (Vs)    ±18V 
 
Current Consumption (Is)      200mA 
  
Data Update Rate (**)             Display Mode - Digital 40 Hz for single head  

Scope Mode – Digital 4KHz up to 2000 points in memory 
(position) 

  8 KHz up to 4000 points in memory (power) 
                                                 Analog Mode - 30 KHz max speed for 9*9mm PSD, or 
                         60 KHz max speed for 4*4mm PSD 
 
Response time (Analog)       <60µS for 9x9mm PSD 
            <20µS for 4x4mm PSD 
 
Minimum detectable           1mV (CW) / 5mV (Pulsed)   
Deviation (CW/Pulsed) (***) 
 
Environmental                        Operating temperature Topt : 00 - 500C 
 
 
Weight                                     Sensor head with lens and 3m long cable 175gr 
 
 
ND Filters                                Optional per special order (ND / Red filter / BandPass filter) 
 
 
(*) To maintain full calibration accuracy, attenuating optical filters (ND) may be necessary for 
operation with beams greater than 1mW. Saturating “non-linear” effects depend on the beam 
size, type and wavelength. Caution should be exercised when using the lateral effect detector 
above 1-3mW. 
 
(**) See Speed Issues. Data Update Rate at Display Mode depends on computer resources 
and other application programs that run on same computer in parallel. 
 
 
(***) Conversion factor: 1mV = 1µm for 9*9mm PSD 

      2.5mV = 1µm for 4*4mm PSD 
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Power Supply Specifications 
 
The OBP Series - USB version contains a universal switching power supply, having the 
following specifications: 
 
Input Voltage:  90-264 Vac typical 
Input Frequency:  47-63Hz 
EMI:  Meet EN55022/FCC Class B 
Output Wattage:  10W 
Line Regulation: 0.1% typical 
Load Regulation:  +/-1.5 – 3% typical 
Noise & Ripple:  Typical 1% peak to peak 
Safety Standard:  UL1950 / EN60950 Class II 
 
 
 
 
External trigger Specifications 
 
For Single Mode only with Scope function! 
 
Trigger Source (external digital):  TRIG_IN 
Trigger mode (software selectable):  Level Sensitive, user configurable for TTL level  

          high input 
Trigger latency:   25µs min, 50µs max 
Trigger pulse width:   40µs min 
Input high voltage:   3.0V min, 15.0V absolute max 
Input low voltage:   0.8V max 
Input leakage current:   ±1.0µA 
 
 
 
 
 
 
Sensor head: 
 
Dimensions (Default)             37 mm diameter, 11 mm long,  
                                                         aligned to detector axes to <±0.5° 
Type                                               Dual-axis Lateral Effect sensors 
Cable                                      3m long, attached to sensor head 
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Figure 1: OBP Series - USB version sensor head dimensions 

 
 
Manifold Box 
 
Device type: USB 2.0 
Device compatibility: USB 1.1, USB 2.0 
Weight: 215 gram with 1.8m USB cable 
Supply current: 20mA 
 
The manifold box plugs into the interface USB device via a 1.8m long USB cable and has 
sockets for 2 x 9 pin connectors. The Male D-Type 9 pin connector plugs into the PSD head. 
The Female D-Type 9 pin connector plugs into the Power Supply.  
 
The manifold box has 2 x LED lamps, which light up as follows: red light when the computer 
power is On, green light when the USB port is being connected. 
 
The manifold box has a socket for Input trigger (see External trigger specifications). 
The software has a built-in Test Hardware operation, which checks the SN of the sensor 
head/s being connected to the USB device/s at a certain moment.  Note: In order to change 
the # of USB devices being connected to the computer there is a need to restart the 
application program and then Test Hardware routine will resume.  
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Figure 2: Manifold box schematics 
 
 
 
 
 
Speed Issues 
 
Benchmark data has been compiled from a Pentium IV, 2.4GHz, 256 MB RAM, Windows XP 
Pro, Screen resolution 1024x768 machine, having a USB port. 
 

 The update rate at Display Mode was 40 Hz for a single measuring head, same speed for up 
to 8 PSD’s simultaneously. This is the maximum rate the software can acquire data when only 
one graphics screen (Position) is open for one measuring head. When several windows are 
opened each one will slow down the system. Faster computers may display the data faster.  
 
The update rate of a particular computer will be influenced by a variety of factors; CPU Speed, 
Computer RAM, Video RAM, Screen resolution, Screen color depth etc.  
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3.0  
Operation – Analog Mode 
 
Before using the device please pay attention to the following issues: 
 
• The input beam should not exceed 100mW/cm2, otherwise the electronics/detector might 

be damaged.  
 
 
Timing Diagram 
 

 
Figure 3: Timing Diagram 
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3.1 Output Schematics 
 
The following block diagram illustrates the connection and operation method of the OBP 
Series - USB version: 
 

 
 

Figure 4: Connection method 
 
 

• Connect the power supply 
• Connect two Voltmeters, one for X measurement and one for Y measurement. 

Alternatively, you can connect a dual-channel Voltmeter 
• Connect the measuring head to the manifold box 
• Place the laser beam in front of the measuring head, while making sure the beam is 

shined exactly at the detector’ center  
• Make sure that the laser power is not exceeding the limits (High Attenuation / Low 

Attenuation, see Specifications section) 
 
 
Things need your attention before conducting a measurement: 
 
• Make sure the beam is aligned close to the detector’ center and not shined at the detector’ 

edges 
• Make sure the red LED on the manifold box is lit. If not – there might be some fault 

operation of the unit, or a wrong voltage was applied. 
• Make sure the sensor head is not saturated, if necessary mount a filter in front of it. 

Saturating non-linear effects might occur (see Specifications section). 
Check saturation at Power Pin; if reading exceeds 10V then the electronics is saturated. 

• Make sure there is no ambient light affecting your measurement. Check the ambient light 
at Power Pin (the voltage output value should be held to ±10 mV). Design an appropriate 
light-shielding to maintain this illumination level, or use the hood offered as the system’ 
accessories.  
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The following diagrams present the effect of ambient light on the measurement accuracy: 
 
 
 

 
Figure 5 : Ambient light effect on measurement accuracy 
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4.0 
Setup 
 
These topics cover the basic procedures for installation, setup and configuration of the OBP 
Series - USB Version. 
 
 
 
Quick Start 
To begin using the OBP Series - USB Version: 
 
1. Check “Hardware Requirements” on page 19. 
2. Follow “Installing the USB device” on page 19. 
3. Perform “Verifying the installation” on page 21. 
4. Perform “Software Installation” on page 24. 
5. See “Running the software” on page 24. 
 
 
 
 
4.1 Hardware Requirements 
 
To run the OBP Series - USB Version, the computer system must meet the following minimum 
requirements. Where helpful we provide system recommendations: 
 
 
Item Minimum Requirements Recommended 

Requirements 
CPU Pentium III, 800 MHz Pentium IV, 2.40 GHz 

System RAM 64MB RAM 256MB RAM 

Hard disk 10MB HD free  

CD ROM drive Any type  

Operating system Windows 2000 / XP / Vista / 7  

Mouse Microsoft mouse or equivalent  

VGA display 800 x 600 resolution 1024 x 768 resolution 

VGA USB device 2MB 256 color 8MB, 16 bit 

USB device socket One USB 2.0 socket 
 

 

           
                     
4.2 Installing the USB device 
 
To connect the OBP Series - USB Version device to your computer system do the following: 

- Connect the sensor head to the manifold box via the 9-pin Male connector, secure the 
connector firmly using the connector screws 

- Connect the power supply to the manifold box via the 9-pin Female connector and 
connect the power cord to the power outlet 

- With your computer On connect the USB cable into a USB port on your computer, or 
into an external USB hub that is connected to the computer. 
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F Never change the amount of USB 2.0 devices being connected to the computer while the 
program is running! If there are any changes made to the # of USB devices connected 
there is a need to Restart the program.   

 
When you connect your device for the first time, the “Found New Hardware” dialog window 
appears. When running Windows XP this dialog is replaced by a notification in the lower right 
side of your screen. 

 
 
A second “Found New Hardware” window appears after the first closes. When running 
Windows XP, this dialog is replaced by a notification in the lower right side of your screen. 
 

 
 
When running Windows Vista this dialog is replaced by a notification in the lower right side of 
your screen. 
 

 
 
A second “Found New Hardware” window appears after the first closes. When running 
Windows Vista, this dialog is replaced by a notification in the lower right side of your screen. 
 

 
 
When the second window closes, the installation is complete. The green LED on the manifold 
box should flash three times and then remain lit. This indicates that communication is 
established between the USB device and the PC. 
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 4.3 Verifying the Installation 
  
To makes sure that your USB device was detected correctly by your operation system perform 
the procedure that is applicable to the operation system running on your computer.  
 
4.3.1 Verifying the Installation for Windows 2000/XP 
 
To verify your device installation on Windows 2000/XP follow the steps below: 
 

1. On your desktop click the right mouse button on the My Computer icon.  
 

 
 

2. From the pop-up menu select the Properties option. 

 
 
The system Properties screen appears, as shown below: 
 

 
 
3. Click on the Hardware and then on the Device Manager button. 
A device manager screen similar to the one shown below appears. Depending on your 
computer setup, some entries may vary. 
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4. Click on the “+” symbol next to the Human Interface Device to expand that entry. 

 

 
 
There is one USB Human Interface Device listed for each USB device being connected 
to the system. 

 
 
 
 
 
 
 
4.3.2 Verifying the Installation for Windows Vista / 7 
 

 
1.  From the Control Panel select the System option. 
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2. Click on the Device Manager button. 
A device manager screen similar to the one shown below appears. Depending on your 
computer setup, some entries may vary. 
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3. Click on the “+” symbol next to the Human Interface Device to expand that entry. 

 

 
 
There is one USB Human Interface Device listed for each USB device being connected 
to the system. 
 

 
 

4.4 Software Installation 
 
To install the OBP Series - USB Version software and run it for the first time, perform the 
following steps: 
1. From the Windows OS desktop select START, and choose RUN. 
 
2. Type E:\SETUP (assuming that “E” is your CD Drive), and press Enter. 
 
3. Follow the Installation instructions displayed on the screen. It is suggested that you accept 
the default settings. 
 
4. Run OBP Series - USB Version, select Start, Programs, OBP Series - USB Version, and 
finally the OBP Series - USB Version Program icon.  
 
5. If the software appears to be up and running without any errors, then installation is 
completed. 
 
6. If you get the following error: “Software can not find the hardware device”, press RETRY. 
Also make sure the manifold cable is plugged into the USB port, or check Installing the USB 
device section. 
 
7. Now you can initiate a measurement cycle. 
 
 
 
 
 
4.5 Running the Software 
 
From the Start Menu, select Programs, then choose OBP Series - USB Version Folder, then 
click on the OBP Series - USB Version program. 
 
 
 
 
 
4.5.1 Configuring Software 
 
Before capturing data, configure the following settings in the software to insure a successful 
first run of the OBP Series - USB Version. 
 
w Select Options from the Main Menu, check the USB Device setting and verify the # of 
devices (ports) match the settings which you previously did. 
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w Press Power button at the ToolBar, press Setup button at the Power panel, select Settings 
Tab and enter the wavelength of your laser source via Wavelength option. Also, you may need 
to update the amount of averaging required for Power. You may increase averaging if values 
vary more than desired. 
 
w Press Power button at the ToolBar, press Setup button at the Power panel, 
   select Settings Tab and enter the amount of averaging required for Power. You may 
   increase averaging if values vary more than desired. 
 
w Activate option PowerScr via Position Setup screen in order to view power reading at the 
Title Bar of the Position window, without the need to open the power measuring window of this 
detector (more room on the screen, slow response, etc.) 

 
 
w When using a single head along with the application program, the following ToolBar is 
displayed enabling control of the various screens / functions of this sensor. 

 
 
When Multiple USB devices are detected, the following ToolBar is displayed: 

 
This ToolBar displays a Tool Tip of Position screen for each detected sensor head, 
additionally there is a selection field enabling the user to toggle between the various head 
SN’s and their additional function screens (Power, Plot, Chart and Scope). 
 
 
4.5.2 Getting Started  
 
This section will provide a short description about using the OBP Series - USB Version and 
utilizing its measuring capabilities as a powerful alignment tool. 
 
Selecting the laser source to be used 
 
Stability 
Selecting the right laser to be used during the alignment routine is a key feature affecting the 
quality of the alignment process. 
For best results - the laser source should be stable, collimated and power stabilized. 
 
Laser maximum power range 
The laser power should not exceed the range of 1 - 1.5 mW. Above this range the laser 
should be attenuated using ND filters (either by placing a filter on the laser itself, or installed at 
the aperture with a special mount). Otherwise, saturating non-linear effects might occur, 
depending on beam size, type and wavelength. 
 
Check the Relative Center setting is not too close to the detector edges 
When using the method of Relative Center measurements towards a point other than the 
origin of axes, make sure that the beam is properly aligned and does not hit the detectors 
edges, or close to them - check that the beam is aligned towards the detectors center 
occasionally. 
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5.0  
System Overview (Display/Scope Modes) 
 
This section covers the basic layout of the system software. 
When the software is started, the main window appears, consisting of display and control 
elements similar to most Windows applications along with elements specific to the system 
interface. 
 
 
Title Bar 
The Title Bar displays the system name followed by the detector head serial number. 
If one inputs data via User Data option via Options Menu this information will be displayed to 
the right of the System S/N  (up to 60 characters). 
The Windows operating system provides special controls in the title bar of a window. From the 
Title Bar the main window can be closed, moved, sized, minimized to icon form, maximized to 
fill the screen. For more information on these controls see the Windows manual or find the 
Windows Tour program. 
 
 
Menu Bar 
The Menu Bar lists menus available for the system. The menus listed in the Menu Bar contain 
commands that allow specific actions to be performed, other sub-menus or dialog boxes to be 
displayed which provide various controls of such functions as graphs, analysis, configuration 
setup, etc. 
 
 
ToolBar 
The ToolBar consists of various icon buttons, which are small symbols that provide quick 
access alternatives to using menus or keyboard equivalent keys to perform various functions. 
To use a smart icon button, move the mouse cursor over the icon and click on the button with 
the left mouse button. To view the function of any icon button, place the cursor on the icon and 
wait momentarily, a brief function description will appear near the icon. 
 
 
Window Area 
This area is for the different data windows. The various windows can be arranged in any 
configuration. The Windows can show Position diagrams, power meter display, strip-chart 
plots of Power versus Time or X, Y Position versus Time. 
Interactive mouse control of each window allows a variety of customized configurations. 
 
 
Using the Menus 
Menus are opened by clicking on the menu title with the mouse, or by pressing ALT + the 
underlined letter in the Menu Title. 
For example: to open the File Menu from the keyboard, simultaneously press ALT and F. 
To select an item within the open menu, click on it with the mouse, or type the letter that is 
underlined in the selection. 
For example: to select Print from the View menu from the keyboard, open the menu by typing 
ALT + F, then type P (the underlined letter) to select Print. 
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Windows appearance 
Moving windows 
Any window can be moved by pointing the cursor at the Window Title Bar at the top of the 
window. Hold down the left mouse button and move the mouse to move the window. 
 
Resizing windows 
Manually 
Windows can be resized by moving the cursor to the edges, corners or bottom of the window 
(the cursor will change to a resizing arrow showing the resize direction), holding down the left 
mouse button, and dragging in the direction you wish to resize the window. 
 
Automatically 
Windows can be minimized or re-expanded using the up/down arrow button in the upper right 
corner of the window. This will automatically reduce the window to its minimum size or re-
expand it if it is at minimum size. 
 
Window icons 
Windows can be changed to icons by clicking on the down arrow button at the upper right 
corner of the window. This keeps the window open and active, but reduces it to an icon at the 
bottom of the screen. Icons can be re-expanded by double clicking on them. 
 
Navigating in the system software 
Selecting various functions in the software can be accomplished by making selections from 
the pull down menus at the top of the screen, or via a quick selection at the ToolBar. 
 
 
 
Keyboard operation 
The keyboard can be used for text data entry as well as control of most OBP Series USB 
Version functions from keyboard shortcuts. 
 
Help 
Press F1 to obtain Help on the active window. 
 
Selection of menus 
w Press ALT and then the arrow keys and then press Enter to select a menu item, or 
w Hold down the ALT key and press the underlined letter (hot key) in the menu name, or 
w Press a shortcut key combination. Shortcuts are available for some menu items and are 
displayed next to the menu item. 
 
Close Menu 
Press the ESC key. 
 
Dialog Boxes 
w Text Entry - Select the text box you wish to change. Use the keyboard to enter the desired 
text. When the correct text has been entered, press the TAB key to finish data entry and move 
to the next control on the dialog box. If an error is made while typing in text, pressing the 
BACKSPACE key will remove the character to the left of the text cursor and move the cursor 
to the erased location. 
w ESC - This key is used to select the “Cancel” button in a dialog box. This returns value(s) in 
the dialog box to their original value(s) before the dialog box was opened. 
w ENTER - This key is used to select the “OK” button in a dialog box. 
w TAB - This key moves the input focus to the next control on a dialog box. 
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ToolBar 
The ToolBar is a collection of shortcut buttons to menu items that are used frequently. Each 
shortcut is represented by a special icon (picture) and is called a Tool Button. 

8 To activate a tool button, place the mouse over the button and click the LEFT mouse 
button. The button will change both color and shadow to designate the fact that this 
function is activated. Date & Time is presented on the right side of the ToolBar. 

 
 
This is an example of ToolBar when only one single sensor head is activated: 
 
 

 

This is an example of ToolBar when there is a multiple-sensors operation: 

 

Tool Tips 
To find out what a tool button does, rest the mouse pointer over the button for a second. A 
light box will appear for a moment with the name of the tool. 

 

Inactive Tool buttons 
If a tool is not active it will be displayed in a gray outline form. For example, if the data has not 
been entered into Log Setup then the Start Log tool will not be active. 
 
 
Toggle Tool Buttons 
 
The second group of tool buttons turn ON and OFF special display windows. These tool 
buttons act as a toggle switch. When they are ON they are pushed down, when they are OFF 
they are up. 
 
 
 
 
Methods of Data Entry 
Activate Button 

This is one of the methods of data entry to the system  

To activate a functional button located on the instrument screen panel for a fast access to a 
common used function: 

8 Place mouse cursor at the required button and click the LEFT hand button of a mouse. 

7 Activate a Hot key, by pressing ALT button + the Capital letter at the option name. 
 

For example:          
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Activate button Catch located at the Position screen panel for a fast access to Relative 
Center setting. Each time you press this button the system defines the current X,Y coordinates 
as the new Relative center. 
 
 
Switch On/Off 
This is one of the methods of data entry to the system.  

To turn an option On, use the following method: 

8 Place mouse cursor at the required data entry box and click the LEFT hand button of 
a mouse.  A cross mark appears to mark the option On. 

7 Press the Tab key until the cursor is located at the required data entry box. Press 
SpaceBar to select the option On. 

For example:          

Use the above listed data entry box in order to set PowerScr On /Off on the Position screen.  

 

To turn an option Off, use the following method: 

8  Place mouse cursor at the required data entry box and click the LEFT hand button of 
a mouse once more to deactivate the selection. The cross mark is than removed from 
inside the data entry box. 

7 Press the Tab key until the cursor is located at the required data entry box. Press 
SpaceBar once more to deactivate the option. The cross mark is then removed from 
inside the data entry box. 

Press OK button to confirm the selection, or Cancel button to abort settings. 

 

 

 
Value Setting 
This is one of the methods of data entry to the system.  

To set a digital value for a parameter, use the following value entry box method: 

8 Place mouse cursor at the required parameter Up/Down arrow buttons and click the 
LEFT hand button of a mouse in order to view the possible values stepwise, or leave 
your finger pressing the LEFT hand button of a mouse in order to change the value 
consecutively. 

7 Press the TAB key until cursor appears at the required value entry box. Place the 
Write sign cursor at the required location by pressing the SpaceBar key and type the 
characters/digits on your keyboard. 
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For example:       

Use the following value setting box in order to input the Wavelength value of the Laser. Press 
OK button to confirm the selection, or Cancel button to abort settings. 
 
Radio Buttons 
This is one of the methods of data entry to the system.  

To select a value from a short list of options, use the following typical Radio Button entry 
method: 

8 Place mouse cursor at the required button and click the LEFT hand button of a 
mouse. A solid small circle will be displayed inside the option circle.  Another click on 
the mouse LEFT button will deactivate the selection. 

7 Press the TAB key until cursor appears at the required option within the list zone. 
Press the arrow keys to select the option from the list.  

 

For example:       

Use the Radio Button data entry box for Units in order to input the units is use for the current 
session. Press OK button to confirm the selection, or Cancel button to abort settings. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 



OBP Series - USB Version                                                    31 

5.1 Main Menu  
This section provides a general overview of the system Main Menu items. 
The following command Menus are available on the Menu Bar: 
 

 
 
File Menu 
The File menu allows the user to perform many file operations such as: save, view, print, 
delete or transmit data files. It can be used to design time based experiments and analyze the 
data in a variety of ways. 
 
View Menu 
The View menu enables the user to activate the operational functions, either: 
 
w Position measurement system (marked as #1), along with its related presentations (Position, 
   Power, Plot, Chart, Scope), or 
w Both sensing systems as described above, simultaneously. 
 
Options Menu 
The Options menu handles saving system setup configurations, Test Hardware connected, 
save BMP files and insert User Data to be displayed on screen. When the program is 
reactivated, one can load a pre-saved setup file, or the default configuration will be loaded 
automatically ($$$.INI file). 
When “Save settings on Exit” is activated all system’s options and setup screens are saved in 
$$$.INI file. 
 
Window Menu 
The Window menu allows automatic rearrangement of all open windows: Tile Horizontal, Tile 
Vertical, Cascade and Arrange icons. 
 
Help Menu 
The Help menu provides on-line help on all system functions and buttons. The help screens 
are intended to provide short explanations about the current function and guidelines for 
operation. 
One can select the part of Help, which is required, either the Contents Window, the Search 
Window, or information on the current Active Window. 
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6.0   
Operating Instructions 
 
This section provides a complete and detailed overview of the system software. It describes 
the layout of each operating screen as well as its Setup screen. 
 
 
6.1 Introductory Screen 
 
After the program boots-up, an introductory screen will appear. 
This screen lists the name of the instrument along with some more information regarding 
manufacturer, model name, software revision etc. This is a pop-up screen, which disappears 
after 5 seconds.  
 
At this stage the system performs an automatic check of hardware being connected to it, and 
another message is displayed, which is a warning prompt to the user to verify which sensor 
heads are connected to the system, specifying their S/N. 

 
 
                                       
 
 
 
 
 
 
 

    
Click the Close button in order to initiate the measurement cycle. 
The user can cancel this automatic Test Hardware check in future sessions by marking a 
cross mark at the appropriate option box.  Test Hardware function can also be activated 
manually via the Options Menu. 

 
 
6.2 File Menu 

File Menu allows the user to perform various file operations. File operations include: 
Save, View, Print and Transmit data files. Also, It can be used to design time based 
experiments and analyze the data in a variety of ways. Additionally, this function allows the 
user to define a new optic filter, if necessary. 

Upon activation of File function, the following list of options appears: 
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wNote that the list of keys or key combinations on 
the right side of the menu indicate the keyboard 
shortcut for that feature. These shortcuts may be 
activated from the Main Window by pressing the 
keyboard combination. 
wIf a menu item is gray it means that item is 
unavailable until something else is done. For 
example, to start Log it has to be Setup first. 
 

 

Following please refer to detailed information 
about each one of File options: 
 
 

 
 
 

 View File 
View File provides the user the ability to view any stored file, including data Log, Power 
Plot, Position Chart, and INI files.   

View File can be selected from the File menu, the keyboard shortcut Ctrl + V, or via the 
ToolBar. 
To view a file:  

1. Select View File from the File menu. 

2. Select the File Type for the file to be viewed: 
Log files  (*.LOG),  Plot files  (*.PLT),  Chart files (*.CHT), Config files (*.INI), Excel files 
(*.XLS), Scope files (*.SCP), BMP files (*.BM), image files (*.JPG). 

3. There should be no need to change the directory because most files should be stored in the 
system directory (the default). 

4. Click on a file from the file list on the left. 

5. Click OK. The file can now be displayed in the notepad application. 

 
 
 

Copy File 
 
Copy File provides the user with the ability to copy any stored data file to the system 
working directory. 
Copy File can be selected from the File menu, or the keyboard shortcut Ctrl + C. 
 
Specifically, this option is useful for copying an external filter transmission file to the current 
working directory. A message box is displayed during the Copy operation, specifying the 
amount of bytes copied. 
 
To copy a file: 
 
1. Select Copy File from the File menu. 
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2. Select the File Type for the file to be copied: 
    Filter files  (*.FLT) 
3. Select the drive to copy from 
4. Click on the file from the file list on the left 
5. Click OK. 
 
 
Create Filter File 
This option enables the user to define a new optic Filter file.  

Create Filter File function is selected from the File menu, or the keyboard shortcut Ctrl + F. 
Because silicon detectors saturate easily, it is frequently necessary to insert one or more filters 
in front of the detector to attenuate the beam and prevent saturation. Since the wavelength 
response of these filters is not flat, it is necessary to install the transmission properties of the 
filter in the software, in order to obtain a proper power measurement and gain setting for the 
detector amplifier. 

 

The filter file contains: 
A table including two columns.  

wThe first column is the wavelength (in 1 nm steps, or bigger steps). The user can select the 
step size for entering the wavelength data (each, 1 nm, or 5 nm, or 10 nm, etc.). 
wThe second column is the known transmission of the filter for the matching wavelength in %. 

The system uses straight-line interpolation to determine transmission values for wavelengths 
that lie between wavelengths listed in the file. One can create any filter transmission curve 
file within the range of 350 nm - 1100 nm. 

 

Creating a new Filter file: 

1. Select Create Filter File from the File menu. 
 

 

 

 

 

2. There are 3 data entry boxes, each for the line number (No.), Wavelength (nm), and     
Transmission value(%). The data box labeled as “No” starts with the line number value of “1”. 

3. Type the value for wavelength, or change it from the arrow keys of this data box. If a 
wavelength outside the operating range of the detector head is entered a warning will be 
displayed. 

4. Type the percent transmission, or change it from the keys of this data box. 

5. Press Next button to insert the next data line into the Filter file. The data box labeled as     
“No” will display the value of “2”, go back to perform steps 3, 4, and 5 until all the desired     
wavelength \ transmission points have been entered. 

6. Press Complete button, when you are done with the Filter creating procedure. The   system 
will then display a file storage dialog. Press Cancel button to cancel the filter data file 
creation. 

7. In the file dialog there is no need to change the “File Type” because FLT is the default. 
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8. There should be no need to change the directory because the filter file should be stored in     
the system directory (the default). 

9. Type the filename for the filter file in the box below the word "File name". The filename     
must be less than 9 characters and contain no spaces. There is no need to have the file     
name end in .FLT as the program will automatically save the file with that extension. 

10. Click OK. 
 
 
 
 

Print… 
Print…allows the user to print an entire saved data file, either a Text file or an Image file. A 
sub-menu opens up for toggling between Text File and Image File. To select and setup a 
specific printer for printing select Print Setup from the File menu prior to selecting Print. 
 
 

 
To print a text file: 

1. Select Text file… from the Print... menu. 
2. Select the "File Type" for the file to be printed; 

Log files  (*.LOG), Plot files  (*.PLT),  Chart files (*.CHT), Config files (*.INI), Excel 
files (*.XLS), Scope files (*.SCP). 

3. There should be no need to change the directory because most files should be 
stored in the OBP Series USB Version USB directory, (the default). 
4. Click on a file from the file list on the left. 
5. Click OK 

 
To print an image file: 
1. Select the Image file… from the Print… menu. 
2. Select the “File Type” for the file to be printed; 

 
 
 
 

 Print Window 
 The print window function will be printing the currently opened (or active) window. 
 
 
Print Screen 
The print screen function will be printing everything that is currently displayed on the screen. 

 
 

Print Setup 
This option enables the user to load the appropriate printer driver, set the orientation and 
paper size, from the standard Windows Print Setup window. Make sure the appropriate printer 
driver is selected prior to activating Print File. 
 
Print Setup 
Print Setup enables the user to load the appropriate printer driver, set the orientation 
and paper size, from the standard Windows Print Setup window.  Print Setup can be 
selected from the File menu. 
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Make sure the appropriate printer driver is selected prior to activating Print, Print Window or 
Print Screen. 
 

 

Start/Stop Log 
Start/Stop Log is selected from the File menu, or by the keyboard shortcut Ctrl + L, or via the 
ToolBar.  Activate this option in order to initiate a data logging operation, or to terminate a 
current data logging session. The duration of the experiment, the rate of data logging along 
with the filename should be set prior to activating this option through Log Setup function. 

 

  Start Log 
Start Log will initiate a data logging operation. 

Start Log can be selected from the File menu, or from the keyboard shortcut Ctrl + L, or from 
the ToolBar. 

FStart Log button is disabled until the following parameters are configured in the Setup Log 
option: The duration of the experiment, the rate of data logging and the Log filename. During 
Log, the Start Log menu item and ToolBar icon will change to Stop Log. 

 

Once saved, the data can be viewed on screen through View File , printed for reference 
through Print , or transmitted via an RS-232 interface through Link . 

Once saving data is activated, the following banner appears at the top left Window area: 

 

Also, if one moves the mouse cursor and rest it over the Stop Log icon of the ToolBar, a 
small message box appears above the icon, which reads the time to complete the ordered 
Log operation. 

During log operation the Start Log menu item and tool bar icon will change to Stop Log. 

 

 

  Stop Log 
Stop Log will terminate a data logging operation. 

Stop Log can be selected from the File menu, or by the keyboard shortcut Ctrl + L, or via the 
ToolBar. The Log will save data according to the parameters set through the Log Setup.  

The Log operation will automatically terminate after the user-preset time period in duration. 
However, the session can also be terminated by activating option Stop Log in order to stop 
the saving operation at any prior stage. 
 

  Log Setup 
This setup screen allows the user to customize the Log operation to suit a particular need: the 
duration of an experiment, the rate of data saving into file, and the Log filename can be input 
by this setup screen. Also, data can be saved either to a Log file or to Excel file for further 
analysis at a later stage. 
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Log Setup is selected from File menu, the 
keyboard shortcut Ctrl + S or from the Control 
ToolBar. 
 
Upon selecting this function and pressing OK 
button, one can initiate the log file operation via 
Start Log option, in File function. Press Cancel 
button to abandon Log Setup parameters. 
   
 

 

General tab settings include: 

wLogtype:                     LOG file or Excel file 
wFile Name -  Providing the system with a filename where Log data will be saved to. 

Activate Button Browse... in order to provide the system with a 
filename via the standard Windows File Input interface box. 

 
Note:  When LOG file type was selected, all data collected will be saved in a file name *.LOG, 
which is a text file and can be imported into other programs. 
When Excel file type was selected, all data collected will be saved in a file name *.XLS. 
 
 
Settings tab parameters include: 

 
wInterval Insert the time interval between 

 consecutive measurements. The interval can be  

 set in: hours (h button), minutes (m button), or  

 seconds (s button). After selecting h, m, or s  

 parameters, enter the required value for each 

 parameter using the data entry box.   

 

wDuration Insert the length of time during which  

the system is to acquire data. The Log operation 
ends automatically at the end of the period. The logging data operation can be stopped 
prematurely using the Stop Log function. The duration for the measurement can be set in: 
hours (h button), minutes (m button), or seconds (s button). After selecting h, m, or s, enter 
the required value in the data entry box. 

 

wLogtype Provide the system with a method to control the data logging operation: 

- Time:  Save measurements for a pre-defined duration, the interval between the saved 
measurements is also defined prior to saving. 

- Points: Save a certain amount of measurements taken at the system’s data capturing rate, 
the exact figure is entered at the points field to the right of this option. 

- Manual: Save a certain measurement to the file by pressing the SpaceBar. This method is 
called “Event oriented”, meaning once the user observes a certain measurement on the 
screen he can control the system to save this exact measurement data to the file, rather than 
other methods of stream data saving. 
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Log file format: 
w System name and software version. Filename, Date and Time, USB Device SN, Detector 
Serial #, User name,  

w  Wavelength 

w  Null(Yes/No) 

w Filter in use and its name. 

w Average 

w Relative center in use and its coordinates. 

w Boundary setting in use and its value. 

Additionally, for each measurement taken, the following data is saved: Time, Position 
displacement value, and Power of each data point. Also, in case Boundary was preset there is 
an indication for each measurement weather it was exceeded Yes/No. 
 
 
A sample of LOG file output: 
Date:  07 Apr 2014 
Time:  18:59:48 
 
USB Device:                 L9P2-L1014                                 
Detector S/N:                L1014                                      
 
UserName:                                                              
 
Wavelength:                 633(nm)                                    
Null:                              ---                                        
Filter:                            ---                                        
Average:                       ---                                        
Rel.CenterX:                ---                                        
Rel.CenterY:                ---                                        
Boundary:                    ---                                        
 
No            Time          Power1        PositionX1       PositionY1        
              (sec)         (mW)          (mrad)        (mrad)         
 
 1            0.047         1.300         12.695        -11.891        
 2            0.078         1.303         12.695        -11.891        
 3            0.109         1.303         12.695        -11.862        
 4            0.141         1.300         12.695        -11.862        
 5            0.172         1.300         12.695        -11.862        
 
***************  Statistics  *************** 
 
Min                         1.300         12.667        -11.891        
Max                         1.303         12.695        -11.862        
Aver                        1.301         12.695        -11.877        
STD                         0.001         0.004         0.015          

The data saved in Log file correspond to the open windows on the screen: For each sensor 
head being connected and having at least one screen presentation open - the Log will contain 
the following data : Power (mW), X, Y (µm),  

If multiple sensor heads are connected and their appropriate screens are open - then LOG will 
contain information on all detectors, as described above for each one of them. 

At the bottom of the Log file the system presents some statistics regarding the measurements, 
for each parameter: Min (minimum value measured), Max (maximum value measured), Aver 
(average value measured) and STD (standard deviation). 
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F Log Setup is disabled while Log is ON.   

Activate Button Help to get help on this window. Press OK button to confirm, or Cancel button 
to abandon. 
 

 

Start/Stop Link 
 

Start/Stop Link provides the capability to operate an RS-232 or TCP/IP Communication 
channel for data transmission. 

Start/Stop Link is selected from the File menu, or the keyboard shortcut Ctrl + K. Any 
displayed data or pre-saved text file can be transmitted via Link. Typically, this feature is used 
to transfer real time data from the system to another computer over a serial cable or LAN 
cable (RJ-45 connector). The other computer can receive the data using a program that can 
communicate over a COM Port like the Windows Hyper Terminal program. 

While link is in progress, a banner is displayed in the Windows upper left-hand corner of the 
Window area, which reads: 

 
The file/data is transmitted in the background while the system continues to capture data. 
When finished the Linking status message will disappear. To stop a Link in progress, select 
Stop Link from the File menu. 
To transmit data/file over RS-232 or data over TCP/IP: 

1. Connect the system to another computer using a null-modem cable or RJ-45 connector. 

2. Before using Start Link, the Link parameters in Link Setup must be configured to match 

    the communications protocol of the computer that will receive the file/data. 

3. Enable the receiving program to receive the file/data. 

4. Select Start Link from the File menu.  

In case you are transmitting data (option Data in Link Setup): after Start Link is pressed 
the program immediately starts sending measured data via RS-232 or TCP/IP. 

The data transmitted includes the following format:  

Time of measurement, Power (mW), X, Y (µm) of sensor head. 

In case you are transmitting a file (option File in Link Setup): a standard Windows File 
box is displayed. Note: A file can not be transmitted over the TCP/IP protocol. 
5. Select the File Type for the file to be sent:  

    Log files  (*.LOG),  Config files (*.INI),  Plot files  (*.PLT),  Chart files (*.CHT), Scope file 
(*.SCP) 
6. There should be no need to change the directory because most files should be stored in      

the system directory (the default). 

7. Click on a file from the list on the left. 

8. Click OK.   

To stop a Link in progress, when Link is transmitting on-line data select Stop Link from the 
File menu. Link is terminated automatically upon completion of the transmission of a file, or 
can be stopped by selecting Stop Link from File menu. 
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Making a Null Modem Cable   
A null modem cable can be made from a standard RS-232 cable by connecting the pins on 
one end of the cable to the pins on the other end as shown below. 

Null-modem with 25 pins on both sides 

25 Pin Side...                               25 pin side... 

FG      1                                        1     FG 

TD      2                                        2     TD 

RD      3                                        3     RD 

RTS    4                                        4     RTS 

CTS    5                                        5     CTS 

SG      7                                        7     SG 

DSR    6                                        6     DSR 

DCD    8                                        8    DCD  
DTR   20                                      20    DTR 
 

Null-modem with 9 pins on both sides 

9 Pin Side...                                9 pin side... 

DCD     1                                       1     DCD 

RD       2                                        2    RD 

TD       3                                        3     TD 

DTR     4                                        4     DTR 

SG       5                                        5     SG 

DSR     6                                        6    DSR 

RTS     7                                        7     RTS 

CTS     8                                        8    CTS 
(RI)      9                                        20   Unused (RI) 

 

 

 
Link Setup 
 

Link Setup allows the user to configure the system to suit a particular set of 
parameters needed for the RS-232 transmission.  

Link Setup can be selected from the File menu. 

The group of parameters relating to the RS-232 serial link, include: General and Port 
Settings Tabs. 



OBP Series - USB Version                                                    41 

General Tab:  

wCOM: Selects the computer 
communication port, through which data is to 
be transmitted over the RS-232 link. Ensure 
that the selected port does not coincide with 
the port being used for the mouse. Many 
PC's have the mouse installed on COM1. 
The possible values for Port are 1 and 2, for 
COM1 or COM2, and can be entered in the 
data entry box, by Value Setting. 

wTransmit:  a File (pre-saved text file), or 
Data (real-time measurements). Selection is 
made using Radio Buttons. If File is 
selected, the system opens a File Selection 
Dialog box in order to provide the text file 
name & path information. 

 

Port Setting Tab: includes the following four 
parameters setting: 

wBits per second: Selects the transmission 
rate for the RS-232 link. The possible values 
are: 110, 300, 600, 1200, 2400, 9600, 14400, 
19200, 38400, 57600, 115200. This setting 
must match the same setting on the receiving 
computer, and can be entered by clicking on 
the down arrow and selecting the value from 
the list. 
wParity Bit: Determines whether or not a 
parity bit is to be transmitted. The possible 
values are: None, Odd, Even, Space, Mark. 
This setting must match the same setting on 
the receiving computer, and can be entered 
by clicking on the down arrow and selecting 
the value from the list. 
wData Bit: Determines the number of bits in 
use for the RS-232 transmission. The 
possible values, are: 4, 5, 6, 7, and 8. This 
setting must match the same setting on the 

receiving computer, and can be entered by clicking on the down arrow and selecting the value 
from the list. 
wStop Bit: Determines the number of stop bits to be transmitted. The possible values, are: 1 
or 2. This setting must match the same setting on the receiving computer, and can be entered 
by clicking on the down arrow and selecting the value from the list. 
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General Tab:  

wTCP/IP: Selects the computer 
communication port, through which data is to 
be transmitted over the TCP/IP link.  

 

 

 

 

 

 

 

 

 

 

 

Once connected to the TCP/IP port, the Port 
address and Port Number are displayed in 
the Port Settings fields (Host address and 
Port number). 

Any computer in the network that needs to 
communicate with other computer via the 
TCP/IP protocol should provide the Port 
Settings fields (Host address and Port 
number) 

 

 

 

 

 

 

 

 

 

 

 

Activate Button Help to get help on this window. 

Press OK button to confirm, or Cancel button to abandon. 
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Exit 
 
Use Exit to terminate the current session of the system. 
Exit is selected from the File menu. 
 
The following dialog is shown if Save Settings on Exit setting is not enabled: 
 
"All current data will be lost when program is exited - continue?" 
 
It is a reminder to save the setup parameters if necessary. Select Yes to exit. 
 
 
 
 
 
 
 
6.3 View Menu 
 
View enables the user to open functional Windows. All screens can be opened 
simultaneously if required. 

 
 

Available functional windows, are: 
w Power: One can activate the power meter display of the sensor head. 
w Position: One can activate Position screen (for single USB device connected). 
w Plot:  One can activate the power Plot. 

w Chart: One can activate the Position Chart or Position Chart versus Time. 

w Scope: One can activate the scope presentation. 
w Default Set:   One can activate a default setting. 

w ToolBar: Enabling the user to show / hide the ToolBar. 

 
The list of keys, or key combinations on the right side of the menu indicate the keyboard 
shortcut for that feature. These shortcuts may be activated from the Main Window by pressing 
the keyboard combination. A check mark in front of a menu item means that the function is 
enabled. 
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   Power 
Power options control the various power-meter features of the instrument. 

Power can be selected from the View menu, Option Power, or using the keyboard shortcut 
F2, or via the ToolBar. 

The displays show real-time power information, both a needle-graph and a numerical 
presentation. 

The power meter presentation includes both a needle graph display, along with a numerical 
display (in mW, µW, or dBm units). All the power setup options refer to the needle and the 
numerical power displays, which show real-time power information. 

 

Power control panel include a few buttons, for 
easy and quick control of the Power 
functionality, as follows: 

wNull   button 
wSetup button 
wFilter  button 
Activate Button Null in order to perform 
ambient-light suppression. 
Activate Button Setup in order to set any of the 
Power Setup parameters. 

Activate Button Filter in order to load a pre- 

defined filter transmission file onto the Power measuring function. 
 
 
 
Null 
This option provides for ambient-light suppression and permits accurate analysis of the light 
source examined. 
After activating this option, a message box appears, instructing the user to remove the light 
source and press OK to confirm. 
The system now measures the ambient light level and subtracts it from all future power 
measurements. A prompt will indicate when the measurement has taken place and the laser 
can be turned on again. Null is now On, and a banner appears above the power display, which 
reads Null. 

When Null is turned off, the values displayed are the total power incident on the detector 
surface. 

When Null is turned On, the power value displayed does not contain the ambient light. 

8  To activate / deactivate Null: Place mouse cursor over the Null button and click the Left 
mouse button. 
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Filter 
Because silicon detectors can saturate very easily, it is frequently necessary to insert a filter in 
front of the detector to attenuate the beam and prevent saturation. Since the wavelength  
response of silicon is not flat, it is necessary to install the transmission properties of the filter in 
the software in order to obtain a proper power measurement and gain setting for the detector 
amplifier. This option allows the user to load or remove any pre-defined filter transmission file 
onto the power measuring function of the instrument. 

w Create a Filter file through File menu, Create Filter File option. A custom filter file can be 
created via this option. 

w Pre-Load a Filter file to the system via Power Setup: after physically installing the filter in  
front of the detector. This is done in order to inform the system, which filter to use in the 
current session. Click on the Load button. A file list is displayed, presenting all the available 
filter files to choose from. Confirm selection from the file list and press OK button to continue. 

w Activate Button Filter at the Power meter panel to activate a pre-loaded Filter file onto the 
power measuring function of the system. A banner appears above the power display, which 
reads the Filter filename. 

w Activate Button Filter again to deactivate the Filter file from the power measuring function of 
the system, and physically remove the filter from the sensor head. 
 
 
 
Power Setup 
Power Setup allows the user to configure the power measurement capability to suit a 
particular set of needs.  

Power setup can be selected from the Setup button at the Power meter panel. 
Power Setup includes the following options: Settings, Zoom&Limits, and Hardware Tabs. 

wSettings Tab options are: 
Wavelength: For setting the wavelength 
of the laser source in use 

Units: For changing the units of the 
power meter display 

Power Average: For averaging the 
power reading, by smoothing the display. 

Filter: For loading / removing a filter                                                                              
transmission file.  

 
wZoom & Limits Tab options are: 

Power Zoom:  For magnifying the 

measurement area, in order to more  

easily detect small variations in beam  

power. 

  Limits: For setting an area within the 

  needle graph display, to warn the user 

  if power drifts outside the zone. 
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Activate Button Help to get help on this window. Press OK button to confirm setting, or  
Cancel button to abandon. 

wHardware Tab option include:  

Detector:  For identifying the detector S/N in use. 

 
Following please refer to a detailed description of the above setup parameters: 

 

Wavelength 

Wavelength can be selected from Power Setup, via Settings Tab. 

The wavelength value is used by the Power function to correct the sensor reading for the 
selected wavelength response. Because the system uses Silicon detectors, it is important that 
the proper wavelength be entered. If the proper wavelength is not entered, power readings will 
be inaccurate. 

This option should be used to input the wavelength (in 
nanometers) of the laser source used in the current 
measurement session. 

The system will recalculate the beam power value and 
correct the display accordingly. 

Change the wavelength value by Value Setting. The wavelength can be entered in 1-
nanometer increments from the data entry box. Possible values for wavelength are: 350 - 
1100 nm. 

 
 
Units 

Units option enables changing the units of the power meter display. 
The units, which can be selected , are: mW (milliWatts),  µW (microWatts),  dBm (Decibels). 

Both the needle scale and the numerical power display are updated accordingly. 

  Select the required option by using the Radio Buttons. 
 
 

Average 
This option activates/deactivates the beam power averaging function. 

This is a successive averaging feature which smoothes the Power display of "noisy" or 
unstable lasers. 

When Power Average is On, minor fluctuations in power are smoothed out and the display 
becomes easier to read. Average can be set to any value between 1 through 20, where 1 
means "no averaging", and every measured value is displayed. 

Switch On/Off Average in order to activate/deactivate the power averaging function. All the 
power displays are affected accordingly. 

Average value: One can select any value between 1 through 20 for Power Averaging, by  
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Value Setting. If, for example, 5 is selected, then five successive measurements are Power 
Averaged, and the Averaged Power result is displayed. 

In the averaging process, when a sixth measurement is made, the first measurement is 
displayed and the Power Average of the second through seventh measurement is calculated 
and displayed. This value determines the number of successive measurements that will be 
averaged to yield the displayed result. Because a successive averaging technique is 
employed, the window display update rate is only slightly affected (if at all). 
 

Filter 
Because silicon detectors can saturate very easily, it is frequently necessary to insert a filter in 
front of the detector to attenuate the beam and prevent saturation. Since the wavelength  
response of silicon is not flat, it is necessary to install the transmission properties of the filter in 
the software in order to obtain a proper power measurement and gain setting for the detector 
amplifier . This option allows the user to load or remove any pre-defined filter transmission file 
onto the power measuring function of the instrument. 
Filter option is used in order to inform the system which filter file to use in the current session 

Pre-Load a Filter file to the system via Filter - Load file button ,after physically installing  the 
filter in front of the detector. A file list is displayed, presenting all the available Filter files to 
choose from (all files having extension name *.FLT). Confirm selection from file list and press 
OK button to continue. 

 

Detector 
 

Detector is provided for reference only - identifying the detector serial number, which is 
currently connected to the system. 

Detector option can be selected, either from the Position Setup - Hardware Tab, or from 
Power Setup - Hardware Tab. 

The detector S/N is composed of 5 characters: A letter A (which stands for Position), followed 
by 4 digits. 

 
Zoom 

Zoom magnifies the beam power display.  Zoom can be selected from Power Setup - 
Zoom & Limits Tab. 
The needle graph display is affected accordingly. This is a useful feature when monitoring 
small changes in beam power. 

Define the Zoom area by setting the minimum and maximum power levels from Min or Max 
accordingly, from the data entry box. 

wMin/Max  
Set the minimum/maximum levels allowed for the power measurements in order to aid 
monitoring the power change in the area of interest. 

Define the Power Zoom area by setting the Min/Max levels. 

The Min/Max values permitted are: 

mW:          0.001 - 2.500  mW 

µW :           1 - 2500  µW 

dBm:         -30 - 4  dBm 
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Change the Min/Max levels by Value Setting. 
If Min/Max levels have been defined and the Beep is On, both audio and visual alarms will 
warn the user if the power drifts outside the zone. 

 

F Limits Min value should be  >= Power Zoom Min limits  

        Limits Max value should be <=  Power Zoom Max limits.    

 

 

 
Limits 
 

Limits function define an area within the needle graph Power display, where audible or 
visual signs will warn the user if power drifts outside this zone.  

Limits can be set via Power Setup -  Zoom&Limits Tab.  

The allowed zones are marked in black color, while non-permitted operation zones are 
marked in red color on the needle graph. 

Limits Options are:. 
wOn:   Switch On/Off Limits in order to activate/deactivate an alarming zone when the            
measured power level is violated. 
wBeep: This option will generate an audible warning in case the measured power exceeds the 
pre-set Min/Max limits levels. Switch On/Off Beep in order to activate/deactivate the beep 
sound when the measured power level is violated. 
wMin/Max: This option enables setting the minimum/maximum levels allowed for the power 
measurements in order to aid monitoring the power variations. Change the Min/Max levels by  
Value Setting .   
If Min/Max levels were defined and Limits is On, both audio and visual alarms will warn the 
user if the power drifts outside this zone. 
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  Position 
Position window provides a real-time display of beam position deviations.   

Position can be selected from the View menu, or 
using the keyboard shortcut F3, or from the 
ToolBar. 

The system acquires and displays the information 
both numerically and graphically.  The detecting 
area of the sensor is represented as a rectangle 
with a stationary cross-hair target. 

Audible and visual alarms will alert the user when 
the centroid of an incident beam moves outside of 
this rectangle. 

The stationary cross-hair target represents the 
center of the sensor. The location of the centroid 
of the incident beam is graphically represented by 
a small moving cross. This cross tracks the beam 
by moving in accordance with its real-time 
changes in Position. Numerical values of the 
beam Position with respect to the center of the 
detector are displayed as X and Y coordinates (in 
mRad). 

Activate Button Setup in order to set required 
values for any one of the Position screen parameters. 

Activate Button Catch in order to set the new relative center coordinates as the current 
coordinates displayed at the time Catch is activated.  All Position measurements will be taken 
relative to this point. Option Catch can be activated only after one sets the Relative Center 
function On via Position Setup - Target Settings Tab. 
Activate Button Zoom - Up Arrow  in order to magnify the cross-hair target of the 
measurement area. Each time you press the Up arrow button the scale is magnified twice the 
previous scale. 

Activate Button Zoom - Down Arrow in order to view the measurement area on a bigger 
scale. Each time you press the Down arrow button the scale is smaller twice the size of the 
previous scale. 

F  Zooming in and out is possible up to 11 times. The Zoom Up/Down buttons located at 
the Position screen panel provides for a quick zooming operation. One can also adjust 
the target size by activating Position Setup function - Target Tab, option Zoom. 

 

Position Setup 
Position Setup allows the user to configure the system to suit a particular set of needs while 
measuring beam angular deviations. 
 
Position Setup is selected from inside the Position Window.  
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Position Setup includes the 
following sub-menus: 

- Options, 

- Target Settings, 

- Hardware,  

which are accessed via the Tabs. 

 

 

 

 

 

wOptions settings, including: 
PowerScr:  For displaying the Power value at the Position Window Title Bar 

Average:    For averaging the Position readings by smoothing the display 

Trace:         For easier tracking of beam angular displacements 

Sound:    Setting an audible alarm with respect to exceeding the detector physical 
dimensions. 

Device name: Set a name for the device 

 

wTarget settings, including: 
 

Zoom: For magnifying the measurement 
area in order to detect small variations in 
beam Position. 

Boundary:  For defining a diameter inside 
the detector area, to aid in monitoring beam                    
angular stability. 
Relative Center: For defining a point on the 
detector surface as the point relative to 
which the beam Position is to be measured. 

 

 

wHardware settings, including: 
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Detector: For identifying the 
detector S/N in use 

Flip Control: For toggling between the X-Y 
axes presentation direction 

 

 

 

 

Activate Help button in order to get help 
about the setup parameters. 

Press Ok button to confirm setting, or Cancel button to abandon. Following please refer to 
detailed explanations about the Position Setup options. 

 

 

 
PowerScr 
 
PowerScr enables the user to view the Power readings while watching the Position screens, 
without the need to open additional Power Window. 
 

 
 
PowerScr is selected from the Position Setup Window. 
Switch On/Off  PowerScr option to activate / deactivate this feature. 
 
When PowerScr is On - the Power readings of the detector are displayed at the Position 
screen Title Bar, so there is no need to open the Power meter presentation (more room on the 
screen, slower speed, etc.) 
This feature is most useful when performing the system setup alignment prior to actual 
measurements. 
 

 
 
Average 
 
Average function is used, in order to smooth the Position display of quickly varying sources. 
Average can be set via Position Setup, Options Tab. 
When using a beam with significant amount of jitters, it is sometimes convenient to set this 
feature On. 
 

When Average in On, a few successive position measurements are averaged and displayed. 
The amount of successive measurements averaged can be controlled via this option (possible 
values are 1 - 100 ), where 1 means "no averaging" and every measured value is displayed. 

When, for example, a value of 10 is chosen, ten consecutive measurements are averaged 
and the result is displayed. When an eleventh measurement is taken, the first measurement 
value is dropped and the second through the eleventh are averaged, etc. 
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Because a successive averaging technique is employed, the window display update rate is 
only slightly affected, if at all. 

Upon activation, a few consecutive position measurements are averaged and displayed. The 
amount of consecutive measurements averaged can be controlled via this option. 

Follow the steps for setting Average: 

wSwitch On/Off Average button to activate / deactivate the Average On / Off setting. 
wInput value for Average via the data entry box by Value Setting. 

 

 

Trace 
 

Trace graphically traces the beam wondering on the detector surface, leaving a mark of each 
measurement taken, so historical movement of beam can be observed on the display. 

Trace can be selected from Position Setup, Options Tab. Switch On/Off Trace button to 
activate / deactivate this option. 
 

 
 
Trace graphically traces the beam wondering on the detector surface, leaving a mark of 
each measurement taken. 
 
Successive:  This is the Trace default. When Successive in On, the trace marks are 
                      drawn continuously over the measurement area. 
 
Descrete:  When Descrete is On, the trace marks are drawn only upon instructing the 
software to record the last measurement taken: press the Alt + X keyboard combinations in 
order to draw the location of last measurement as a trace mark on the measurement area. 
This option is most useful for cases when alignment of various optical paths is required. 
 

F To clear the trace marks quickly from the measurement area - press double clicks on 
the mouse LEFT button. 

 
Sound 
Sound is provided to activate / deactivate an audible alarm when the beam drifts outside the 
detector physical limits. 
Sound can be selected from the Position Setup Window.  
 
Switch On/Off Sound in order to enable / disable the alarm when beam is outside the detector 
limits. 
 

 
Flip Control 
Flip Control is selected from the Position Setup Window. Flip Control enables flipping 
between the X-Y axes orientation by 180 degrees (converting up to down or left to right, and 
vice versa). This is useful in specific applications when a mirror is placed in the beam path and 
there is a need to view the Position presentation on a different scale. 
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Zoom 

Zoom enables the user to magnify the measurement area, in order to more easily detect small 
variations in beam Position. 

Zoom can be selected from the Position Setup, Options settings. 

Insert the value for Zoom by Value Setting to the required zoom scale. 

Once a zoom scale has been selected the Position display is immediately modified to show 
the magnified portion of the measurement area. 

F For a fast Zooming operation when using the Position screens - use the Zoom arrow 
buttons located at the Position window screen panels. Each press on the arrow 
buttons will magnify / shrink the target presentation by a factor of two. 

 

 
Boundary 

Boundary function activates / deactivates a user-selectable boundary size within the 
detector area. 

The Boundary can aid in the alignment of the beam or in monitoring its pointing stability, by 
setting a limit beyond which alarm will sound (when Beep is set On), or only visual alarm will 
be observed.  
Boundary can be set via Position Setup - Target Tab for the Position sensing detector. 

Switch On/Off Boundary to activate / deactivate Boundary setting. 

Change the value for Boundary by Value Setting using the related data entry box. 
After these operations are done and OK button is pressed, a Boundary having the defined 
dimension is displayed, thus allowing visual alarms to the user if the beam drifts outside this 
zone. 
 

 

Relative Center 
 

Relative Center allows the user to define any point on the detector surface as a point relative 
to which the location of the beam is to be measured. In normal use (When Relative Center is 
Off) the Position of the beam is measured relative to the center of the detector, which has the 
X, Y coordinates 0,0. 

 

Relative Center can be selected from Position Setup, Target Tab, Relative Center option. 
When a Relative Center is defined, this point becomes the origin of coordinates and the 
beam's location is then measured relative to this new origin. 
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This option is useful for monitoring small changes in the beam position around a point, other 
than the detector center. 

 

Follow these steps when setting Relative Center: 
- Switch On/Off Relative Center check-box  

- Activate Button Catch in order to set the current X and Y coordinates as the new Relative 
Center towards which measurements will be taken. 
The current X and Y coordinates are displayed in the Relative Center box. 

If the user needs to set a Relative Center other than the current beam location (as done by 
Catch), after switching on Relative Center, one can change the value for Relative Center by 
Value Setting in the related data box. 
 

 
Detector 
Detector is provided for reference only - identifying the detector serial number, which is 
currently being connected to the system. 

Detector option can be selected from the Position Setup - Hardware Tab, or from Power 
Setup - Hardware Tab. 

The detector S/N is composed of 5 characters: A letter A (which stands for Position), followed 
by 4 digits. This is an informative field, which cannot be modified. 

 
 

  Plot 
Plot provides a strip chart display of beam Power versus Time.  

Plot can be selected from the View menu, or the keyboard shortcut F5, or via the ToolBar. 

The graph presentation includes the temporal power fluctuations. These charts enable the 
user to observe long term power fluctuations.  

Plot control panel includes a few 
buttons, for easy and quick control of 
the Power Meter functionality, as 
follows: 

wPause   button 
wReset   button 
wSave... button 
wSetup  button 
When Plot is activated, the system 
automatically begins plotting data 

points, and an elapsed time clock appears, as well as the number of points accumulated.  
wActivate Button Pause in order to temporarily suspend the Plot data collection. Press the 

button again to continue. 
wActivate Button Reset in order to reset all accumulated data for the Plot function (history of 

current session, including all data points taken). 
wActivate Button Save in order to save data of the past 500 measurements displayed via Plot 

function for further analysis at a later time. Data is saved in *.PLT file as a text file. 
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wActivate Button Setup in order to set any of the Plot Setup parameters. 

Plot File structure is:   
General information like: system name, date, S/N, etc. 

A table of time values paired with measured power values (mW).  
Following please find a sample Plot file: 

OBP Series USB Version, Version 2.0  
Det.S/N:   L1001 
File:  C:\OBP Series USB Version USB\L1001.PLT 
Date:  21 March 14 
Time:  19:33:43 
 
Time          Power 
(sec)         (mW) 
 
0.00          0.619 
0.04          0.623 
0.09          0.631 
0.13          0.622 
0.17          0.617 
0.22          0.628 
0.26          0.618 
0.30          0.624 
0.35          0.631 
0.39          0.630 
0.43          0.621 
0.47          0.613 
 
 
Plot Setup 

Plot Setup is used to set any one of the following parameters in order to control the 
Plot presentation. 
Plot Setup can be selected from the Setup button in the Plot Window. 
Set any one of the following parameters in order to control the Power Plot presentation. 
Plot Setup options: 

Time & Units Tab: 

wUnits 
One can toggle units for the Plot presentation:  
toggle between: mW and µW .Select the units 
using the Radio Buttons. 

wTime Scale 
The rate at which the system plots the data for 
the Plot is controlled via this option. Select the 
required sec/div value by Value Setting. 

This option will change the horizontal scale of 
the strip charts. The value can be changed in 
one second increments. The fastest possible 
rate of display is achieved at a sec/div value of   

"Fast". This setting allows the system to operate at the fastest speed possible, given the 
limitation of the host computer. 

 



OBP Series - USB Version                                                    56 

Obviously, the higher and more powerful the computer processor, the faster the acquisition 
rate. The higher the value of this scale, the slower the graph will scroll. 
 

Zoom Tab: 

wZoom 

This feature controls the on screen vertical 
presentations of the strip charts. The vertical 
scale can either be automatically scaled (from 
AutoZoom), or held at a constant value. 
wAutoZoom 

When AutoZoom is active, the system 
continuously adjusts the on-screen vertical 
scale of the power strip chart, to provide the 
greatest level of detail possible. Therefore, 
there is no need for the user to make 
adjustments to the system. 

When AutoZoom is turned Off, the system 
leaves the scale at the last auto scale setting, 
and manual control of the scale can be 

introduced, using the Min and Max data entry boxes. 
 

wMin/Max 

This option enables setting the minimum/maximum levels allowed for the power Plot 
presentation, in order to aid monitoring the power change in a pre-defined zone, for easy 
control of small power variations in the area of interest.   

 

F  When adjusting the Min and Max values avoid a situation where large measurement 
fluctuations may go beyond the maximum and minimum vertical settings, and thus go 
off the plot. 

Activate Button Help button in order to get help on this window. 
Press OK button to confirm, or Cancel button to abandon. 
 

 

  Chart 
Chart function provides a simultaneous real-time strip-chart display of beam Position 
displacements versus time. 
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The Chart Window can be 
selected from the View menu 
(or the keyboard shortcut F6, 
or via the ToolBar. 

 
Chart enables the user to 
observe long term beam 
angular variations. The rate 
at which this information is 
displayed is user selectable. 
The strip-chart data can be 
saved on disk for analysis at 
a later time.  

Chart control panel includes 
the following buttons: 

wPause button 
wReset button 
wSave button 
wSetup button 
 

 

When Chart is activated, the system automatically begins plotting data points, and an elapsed 
time clock appears, as well as the number of points accumulated. 
 w Activate Button Pause in order to temporarily suspend the Chart data collection. Press the 

button again to continue. 
  w Activate Button Reset in order to reset all accumulated data for the Chart (the history of the 

current session). 
  w Activate Button Save in order to save data of the past 500 measurements displayed via 

Chart function for further analysis at a later time. Data is saved in a  *.CHT file as a text file. 
The user is prompted to provide a filename via the Save Chart File dialog box. 

 

 

Chart File structure is as follows: 
General information like: system name, date, S/N, etc. 

A table of time values paired with measured Position displacements (x,y) measurements are 
in µm units. 

Following please find a sample Chart file: 
 
OBP Series USB Version, Version 2.0  
Det.S/N:   L1001 
File:  C:\OBP Series USB Version USB\L1001.CHT 
Date:  21 March 2014 
Time:  19:39:59 
 
Time          PositionX    PositionY 
(sec)         (um)             (um) 
0.00          99.881        -854.444 
0.18          84.521        -829.219 
0.23          90.230        -853.503 
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0.29          81.316        -826.438 
0.34          95.848        -848.448 
0.39          98.707        -840.547 
0.44          82.462        -838.167 
0.50          94.435        -843.616 
0.55          92.994        -832.666 
0.61          96.957        -856.111 
0.66          86.740        -838.189 
0.72          94.429        -837.671 

w Activate Button Setup in order to set any of the chart setup parameters.    
 
 
 
 
Chart Setup 
 
Chart Setup is used to set any one of the following parameters in order to control the  
Position Chart presentations. 
Chart Setup is selected via Chart Window 

wZoom 
The vertical scale of the Chart graph can 
either be automatically scaled (using the 
AutoZoom option), or held at a constant 
value. This option controls the on screen 
vertical presentations of the strip charts. 

wAutoZoom 
When AutoZoom is active, the system 
continuously adjusts the on-screen vertical 
scale of Position Charts (both the minimum 
and maximum limits of the Chart), to provide 
the greatest level of detail possible. 
Therefore, there is no need for the user to 
make adjustments to the system. When 
AutoZoom is turned off, the system leaves the 

scale at the last auto scale setting, and manual control of the scale can be introduced, using 
the Min and Max data entry boxes. 

wMin/Max 
This option is enabled when AutoZoom function is disabled. 
This option enables setting the minimum/maximum levels allowed for the Position Chart 
presentations, in order to aid monitoring the Position changes in a pre-defined zone, for easy 
control over small Position variations in the area of interest. 

Change the Min / Max values by Value Setting using the related data entry boxes. 

F When adjusting the Min and Max values avoid a situation where large measurement 
fluctuations may go beyond the maximum and minimum vertical settings, and thus go 
off the chart. 
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wTime Scale 
The rate at which the system plots the data is 
controlled through this option. 
Select the required sec/div value by Value Setting. 

This option will change the horizontal scale of the 
strip charts. The value can be changed in one 
second increments. The fastest possible rate of 
display is achieved at a sec/div value "Fast". This 
setting allows the system to operate at the fastest 
speed possible, given the limitation of the host 
computer. Obviously, the faster and more powerful 
the computer processor, the faster the acquisition 
rate. 

Activate Button Help to get help on this window. 

Press Ok to confirm the selection or Cancel to abandon. 

 
 

 Scope 
Select Scope from the View menu, in order to view the position or power data in a 
scope type presentation.  

Scope provides a simultaneous, real-time oscilloscope type display of beam position deviations 
(or power fluctuations) as a function of time. These charts enable the user to monitor time 
dependent power fluctuations and observe beam position drift. Data can be saved for further 
analysis and display at a later stage, also one can retrieve and display a saved data file and 
present it via the Scope function. 
 
The following control buttons and functions are available form the Scope panel: 

- Position X Offset / Position Y Offset / Power P Offset: Enables adjusting of each 
presented channel separately, by means of waveform vertical position. Use the arrow 
buttons in order to slide the presentation up and down over the graphical presentation. 

- DC/AC : Performs a DC subtraction for each channel. 
- Zoom: Performs a zooming operation on the oscilloscope presentation. There are 4 

group arrow buttons controlling the zoom-in and zoom-out operations in both vertical 
and horizontal directions. Each zoom-in operation magnifies the presentation by 2, 5, 
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10, 20 and 50, the zoom-out operation performs the opposite operation accordingly. 
The vertical zoom adjusts the oscilloscope vertical scale factor or meter range, while 
the horizontal zoom adjusts the scale factor for oscilloscope or data logger. 

- Hold: Freezes the display of the oscilloscope acquisition. At this stage the Control 
screen is enabled, and the user can view measurement data at specific locations by 
using the scrolling bar. When Control screen is open and Hold is activated, the cross 
mark displayed position X, Y and/or P coordinates.  
When AutoRun option is selected the cursor moves across the Scope screen 
automatically and the appropriate measurement results are displayed. 
 

 

 
 
Press Run button in order to restart scope presentation. 
 
- Setup: Opens a Setup screen for changing parameters of measurement. 
- Resize: Toggles between two scope screens (500 points and 750 points). 
- Trigger:.Single trigger event is activated . In this mode, the Hold button becomes a 

Run button and the system is waiting on hold until a single pulse is obtained. The 
single pulse should be obtained within a few seconds, if not – a message is displayed: 

- “Trigger mode aborted” and later on Trigger mode is deactivated. 
If a single pulse is obtained it is displayed. Press Run button to get the next pulse. 

- Save: Performs a Save data operation. Data is saved as a Text file having an 
extension of *.SCP. The number of data points for the save operation is determined 
via Setup function. There is a range of 100 points through 2,000 points. 

- Retrieve: Performs a Retrieve operation and displays the stored data file from 
memory. If the retrieved file size is below 500 points then the entire file is being 
displayed on screen. If the file is bigger than 500 points, then the user can choose the 
strip of data to be displayed either by Typing a value at the “Retrieve Memory Data” 
Field, or simply by sliding along the bar below the Retrieve Memory Data field. 
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Scope Setup 

 
 
Scope Setup function enables setting a few parameters for the oscilloscope presentation: 
- Mode: Toggles between Power versus Time presentation, Position and Combine 

versus Time presentation. If Position or Combine is selected – one can set 
presentation of Channel X only or of Channel Y only, or both. 

- Grid: Toggles between Grid On and Grid Off 
- Units: Toggles between Volts (Analog data obtained in Volts) and Engineering units 

(µm or mW). 
- Scope Size: Toggles between a Normal display type (500 points presentation) and a 

Large display type (750 points presentation). 
 

 
 
Trigger Mode: Enables control of a Single trigger event.  
 

- External Trigger – Set this option On or off accordingly. 
- Delay – Enables setting the delay value, this is the amount of seconds the system will 

be on hold waiting for the next single pulse event. 
 

In External Trigger mode, the Hold button changes to a Run button and the system is 
waiting on hold until a single pulse is obtained. The single pulse should be obtained 
within a few seconds as defined in the Scope Setup, if not – a message is displayed: 

- “Trigger mode aborted” and later on Trigger mode is deactivated. 
If a single pulse in obtained it is displayed and can be analyzed by the Scope. 
Press Run button to get the next pulse. 
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- Memory Points: Set the number of points to be saved in the scope memory, when 
Save function is activated. The number of points varies between 100 to 2000 points. 

 
- A/D Rate: Set the acquisition data rate. The range is from 500Hz to 4,000KHz and is 

determined automatically according to your computer speed. 
 

 
 

FFT Function 
The FFT mode can be reached by pressing the Hold button and followed by 
selecting either X or Y buttons. A graphical display of Position (X or Y) or of 
power at each frequency is shown. This data is obtained by performing a Fast 
Fourier Transform (FFT) on the data in the SCOPE mode. The vertical scale 
is automatically selected and is not adjustable. The horizontal (frequency) 
scale can be varied and shifted. Within the graphical area, the value of the DC 
or zero Hertz component is displayed. The box labeled Data FFT denotes the 
Frequency (horizontal) and Amplitude (vertical) locations of the Cursor. 
Clicking and dragging with the mouse pointer changes the position of the 
cursor. 
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ToolBar 
                                         Select ToolBar from the View menu, in order to show / hide the ToolBar 

respectively. 

                                         ToolBar is a collection of shortcut buttons to menu items that are used frequently. 
Each shortcut is represented by a special icon (picture) and is called a Tool Button. 

  8 To activate a tool button, place the mouse over the button and click the 
LEFT mouse button. The button will change both color and shadow to designate the 
fact that this function is activated. 

 

 
 
 
 
 
6.4 Options menu 
 

Options menu enables the user to Load/Save system configuration files, save BMP file, 
Set plug-in USB device address and insert User Data. 

 Options menu displayed is in accordance with the hardware configuration (type of interface 
USB device), the difference appears in the fifth line, where the following possibilities appear: 

  
The following commands and menu items are available here: 

   w Load Config      
    w Save Config...      
    w Save Screen Image file 
    w Save Window Image file  

    w USB Device 

     w Server Mode 

            w Test Hardware 

    w User Data 

    w Close All Windows 
    w Save Settings on Exit      



OBP Series - USB Version                                                    64 

                            A check mark in front of a menu item means that the function is enabled. Following please 
refer to the list of available Options: 

 

  Load Config 
Load Config allows the user to load a certain configuration file, where all setup parameters 
are saved. 
Load Config is selected from Options menu, or the keyboard shortcut F8. 

All system configuration files have the same extension name:  *.INI .  

Select the required configuration via the standard Windows Load Configuration File 
interface box. 

To load any pre-saved configuration file: 

                                       1. Select Load Config from the Options menu. 

                                       2. There is no need to change the File Type because INI is the 
default. 

                                       3. There should be no need to change the directory because 
configuration files should usually be stored in the system directory. 

                                       4. Click on an INI file from the file list on the left. 

                                       5. Click OK to load the file. The system will update the window with 
the new configuration. 

  Automatic Configuration: 

  To have the system automatically save the current configuration each time it is closed, select 

  Save Settings on Exit from the Option menu. 

  When this option is enabled, the system will store the current configuration into the default 
configuration file (which is named $$$.INI) every time before it exits. When the program is 
activated later it will automatically load $$$.INI file. 

 In case one needs to set a new configuration when booting the program - delete file 
$$$.INI prior to activating the program. 

 

 

  Save Config 
 
Save Config allows the user to save all system parameters in the various windows, which are 
activated in the required setup file.  

Save Config can be selected from the Options menu, or the keyboard shortcut Ctrl + F8. 

All setup files have the same extension" *.INI". Provide the system configuration file with a 
name via the Standard Windows Pop-Up Save Configuration File interface box. 

    FIn case one selects the name $$$.INI for the setup file, when the program is reactivated it 
will automatically load the save configuration file. 

F In case one does not activate Save Config option or Save Setting On Exit when 
quitting the program - setup parameters of current session are not saved. 

Configuration File contents include: 
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           w Each window' s size and position 

           w Setup settings for each window 

           w User data 

           w Show/Hide ToolBar 

           w Save settings on Exit  

 

 
 
Save Screen Image file 
 
Save Image File enables the user to save a screen graphics into a BMP/JPEG file, in 
order to edit/print it at a later stage. 
 
Save Screen Image File can be selected from Options menu. 
Once this function is selected, the software opens a sub-menu including: 
              - B&W Screen  (or the keyboard shortcut F9) 
              - Color Screen  (Ctrl + F9) 
 

                             
 

The user can either save the graphics in a B&W (Black and White colors), or in full color 
picture, depending on the printer type available. 
 

 

Save Window Image file 
 
 Save Window Image File enables the user to save a current open window graphics into 
a BMP/JPEG file, in order to edit/print it at a later stage. 
 
Save Window Image File can be selected from Options menu. 
Once this function is selected, the software opens a sub-menu including: 
          - B&W Screen  (or the keyboard shortcut F9) 
          - Color Screen  (Ctrl + F9) 
 

                             
The user can either save the graphics in a B&W (Black and White colors), or in full color 
picture, depending on the printer type available. 
 

 
USB Device  
This option is provided in case the software fails to talk to the USB device, and there is a need 
to try switching the USB Devices selected by the software. 
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A check mark is displayed in front of the selected option to mark the current slot selected by 
the software. 

For more information see “Multiple devices operation” section. 

 

 Server Mode  
                                
This option is provided to enable a remote operation of the application program. 

Press the Server Icon  at the ToolBar or select Server Mode from Options Menu.  
 
The following blinking icon now appears at the ToolBar adjacent to the Time field. 
Resting the mouse cursor at the blinking icon the Server Host Address is displayed (for 
identification of the Client computer via TCP/IP protocol.) 

 
At the remote computer (Client) there is a need to install the software from the same system 
CD disk, and start the program. The following message will be displayed: 

“Hardware Error #2 : The software can not find the Hardware Device”. Press Ignore. 

The following message will be displayed: 

“ Would you like to initiate a remote client application?”, press Yes. 

The following screen will be displayed: 

 
There is a need to input the Host Address name of the Server computer. After pressing OK a 
Test Hardware routine will be performed. From this stage and on, the remote client computer 

will be running the same software and all measurements and analysis functions performed will 
be done as if it was the main computer which hosts the hardware.  
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Test Hardware 
 
This routine checks the hardware configuration - how many sensor heads are. Test Hardware 
can be set via Options menu or via the ToolBar. This routine is performed automatically when 
the system is rebooted. 
 

   
 
This function checks if a detector head is being connected to the 9 pin D-type connector of the 
manifold box.  
                                       
If during a measuring session the user removes or connects a sensor head to the manifold 
box - there is a need to "tell" the system about this change, by activating Test Hardware  
function again. This is done manually via the Options menu.  After completion of Test 
Hardware routine only the appropriate functions are displayed and enabled for operation. 
                                     
 

F Prior to performing the Test Hardware routine all operating windows should be 
closed. If some windows are open - they will be closed automatically when activating this 
option. 
 

 

 
User Data 
 
User Data enables the user to insert any information required during his measurement 
session, which does not exceed 60 characters. 
User Data can be selected from Options menu. 
 

 
 
After inserting the user data information and pressing OK button - the information inserted will 
automatically be displayed at the Title Bar, just right to the system name. 
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Close all Windows 
This option enables the user to clear the screen by closing all open screens. 

Close all Windows can be selected from the Options Menu, or the keyboard shortcut  

Ctrl+ W. Make sure you saved the configuration file, or activated Save settings on Exit in 
case you need to save system setup parameters to future sessions. 

 

 

Save settings on Exit 
 

Save Settings on Exit allows the user to save all system's parameters of current 
session in a certain file called:  $$$.INI file. When the program is reactivated, it will 
automatically load this saved configuration file. 

Save Settings on Exit can be selected from Options menu. 

If this option is selected, there is no need for the user to activate Save Config option in order 
to save all setup parameters, and save setup operation is done automatically.  

 
 
 
6.5  Window Menu  
 
Window menu enables the user to perform standard Windows screens arrangement. 
The following commands and menu items are available from this menu: 
 
 

  
 
 
Cascade: This command will attempt to arrange all open windows on top of each other, but 
slightly offset so that it is easier to find the window you want. 
 
 
Tile Vertical: This command will attempt to tile the open windows horizontally along the top 
of the window area.  
 
 
Tile Horizontal: This command will attempt to tile the open windows vertically along the 
left edge of the window area.  
 
 
Arrange Icons: When a window is minimized it is reduced to its icon representation and 
stacked along the bottom of the window area. These icons can be moved around with the 
mouse. To return them to a nicely ordered group of icons along the bottom of the window area 
select this function. This is useful if the icon has got covered up with another window. 
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6.6 Help Menu 
 
The following commands and menu items are available from this menu: 
 

   
 
 
Contents: For help on using help press F1. 
To access the on-line system Help routine, select Contents from the Help menu. The 
contents topic is organized into topics (Alpha-Beth order). To find specific information fast use 
the Search for Help On menu item under the Help. 
Each item is a hypertext link to the help file for that subject. Click the topic you are interested 
in to open the help file for that topic. The Tool Bar at the top of the Help Window contains 6 
buttons to navigate the help topics: 
 
- Contents Button: Returns to the Contents Page 
-  Search Button:   Opens the Search Window 
-  Back Button:      Steps back in reverse sequence (most recent to oldest) through each      
                               previously selected page 
- << and >> Buttons: Browse through help files (forward or backward) 
 
Printing Help topics 
Any help topic can be sent to the printer by selecting the command Print Topic from the File 
Menu. The currently displayed topic file will be printed. 
 
Exporting Help Topics (Copying) 
Any selection can be copied for pasting into another file. Select the text to be copied and 
select COPY from the Edit Menu. 
 
Annotating 
Annotations are user notes that can be added to any topic in the Help file. An annotation can 
be added to any topic. Select ANNOTATE from the Edit menu. The Annotate window will 
appear. Type the annotation in the text entry window and click on the Save button. The 
Annotate Window will close. 
A paper clip icon will appear next to the topic title to indicate there is an annotation to this 
topic. 
Annotations are accessed by clicking on the paper clip icon. This will open the Annotate 
window with the previously saved test. Annotations can be changed by typing new  text entry 
box and clicking on the Save button, or deleted by clicking on the Delete button. 
 
Bookmarks 
Bookmarks are shortcuts to any desired topic in the Help file. To create a bookmark for the 
current topic, select DEFINE from the Bookmark Menu. The Bookmark Define window will 
appear. There is a text entry line at the top of the window for entering the name of the 
bookmark. 
Type a name for the bookmark and click on the OK button. This adds the bookmark to the 
bookmark list. 
To use a bookmark, select it from the Bookmark Menu. The topic will be displayed. 
To remove a bookmark, select DEFINE from the Bookmark Menu. In the Bookmark Define 
window there is a listing of all current bookmarks in the lower text box. Select the bookmark to 
be removed and click the Delete button. 
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Help Search Window 
 
Index Tab 
Contains a command line where topic help is desired, and an index window, which shows the 
closest match is displayed. Type the topic you wish to search for in the command line. The 
index will show matches. Select the proper match and click on the Display button. 
 
Find Tab 
The first time the Find Tab is selected, the Find Setup Wizard window will be displayed. Follow 
the instructions to create a database of words that can be used to search the help files. 
Once the search database has been created, find will use it to find occurrences of the word 
that is typed into the command line anywhere in the help file. Each occurrence will be shown in 
a matching words list. Each word in the matching words list can be selected and the various 
topics containing the word will be shown in a topics list. Select the desired topic and click on 
the Display button to display the help file for the topic. 
 
 
Search For Help On: To find help quickly select Search for Help On from the Help menu. 
This will bring up a list of all the topics in the help system. Type the first few letters of the topic 
of interest. The search engine will automatically select any topic that matches the entry. If no 
entries match your topic scroll through the list to see a find a related topic. 
 
 
Active Window: To get context-sensitive help quickly, select F1 or select Active Window 
from the Help menu. This will bring up the help topic for the current active Window. 
General explanation of the features of the active window can be displayed by selecting the 
command Active Window from the Help Menu. This will display the help file for the currently 
active window. 
 
Newport on the Web… : This option performs a direct link to the Newport website, for 
further support if necessary. 
 
About: The About box is selected from the Help menu. This is your typical Windows about 
box showing copyright and contact information. 
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7.0   
Multiple devices operation 
The system provides a capability of measuring multiple USB devices being connected to the 
same computer, via a number of USB ports or via a USB hub. 

After starting the application program, an automatic test is performed in order to locate all 
USB devices being connected. The following message appears: 

 
 

Upon completion of the USB port scanning, a Test Hardware screen appears, naming all the 
measuring heads found. 

 
Press Close button to start the application program. 

The ToolBar of the multiple devices (in this example 3 devices are found) is displayed: 

  
Each device has a Tool button for activating an Position Screen, several screens can be 
viewed in parallel. 

 

Additionally, for one selected sensor head it is also possible to view additional screen 
presentations including: Power, Plot, Chart and Scope. 

Select the active USB device for further analysis and presentation via Options Menu, USB 

Device function as showed below, or via the  selection field in the ToolBar. 
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8.0  
Troubleshooting 

Most of the trouble reported by users of the OBP Series -USB Version fall into a few 
categories.  

The following sections list of some common problems and probable solutions. 

If after reading these sections and rereading relevant portions of the help system you still have 
a question, please refer to us for Customer Support. 

 

System Errors 
Too low power This error is displayed on the right hand side of the Position Window or Power 
Window.  

This message means that the detector is not getting enough laser light. This error will occur if 
less than specified amount of energy is detected. Check that the laser light is reaching the 
sensor. This message also may appear when the sensor head is not connected to the 
manifold box. 

 

 

Too powerful laser This error is displayed on the right hand side of the Position Window or 
Power Window.  

This message means that the detector is getting too much laser light. This error will occur if 
more than specified amount of energy is detected. Provide a proper attenuation. 

 

 
Optical detector L???? is not calibrated with Lyyyy manifold box. Would you like to 
continue? This error is displayed when the sensor head is not connected to the manifold box. 
Please check connection of sensor head to manifold box Ayyyy. 
 
 
Optical detector Lxxxx is not calibrated with Lyyyy manifold box. Would you like to 
continue? This error is displayed when a sensor head being connected to the manifold box 
was not originally calibrated with the same manifold box (not a matching set). The system can 
continue the operation if Yes is selected, or the application program is terminated when No is 
selected. 
Please note that when running parts (sensor head and manifold box), which are not a 
matching set, which were calibrated together, there might occur some inaccuracies beyond 
specifications. 
Operating Errors 
 
The software can not find the hardware device.  This message box appears in a few 
possible situations: 
 
When this message is displayed along with a Hardware Error #2 indication, this means that 
the hardware is not properly connected or missing. Check that the manifold box is firmly 
connected to the USB port and Retry. If Abort is selected the application program is 
terminated. If Ignore is selected the following message appears: “Would you like to initiate a 
remote client application?” 
If selecting Yes the program will start a client server mode of operation. 
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When this message is displayed along with a Hardware Error #3 or Hardware Error #4 
indications, this means that there is some failure in the installation routine, and there is a need 
to uninstall the software and install it once again later on. 
 
 
 
Error in the …\$$$.INI file .    This message box appears when the system default 
configuration file $$$.INI is out-of-date (old INI configuration file) and there is a need to 
remove this file from the working directory. 
 
 
 
Other Windows applications run slow, or appear to get interrupted 
Because OBP Series - USB Version most constantly collect and analyze data it may work well 
with all windows applications. If you want to use another application while the system is 
running, select About from the Help menu. This will cause system to pause the data 
collection. With the About box on the screen, switch to the other application. 
 
 
 
 
Erroneous measurement 
Check that your beam is not saturated, mount an ND filter if necessary. 
Check that the ambient light is not reaching the PSD and provide a proper light-shielding. 
Check the timing diagram and compare to your beam pulse width: the pulse width should be 
bigger than the response time. 
 
 
No Red LED light on manifold box 
Check that your power supply is connected properly and is On. 
Check the voltage connection (check that +/- polarization was not switched) 
 
 
 
No Green LED light on manifold box 
Check that the USB connector is firmly connected to the USB port. 
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9.0 
ActiveX Software (for Windows XP) 

 
9.1 Introduction 

 
The OBP Series – USB version is a full capture and analysis package with sophisticated 
capabilities. However, many customers have special analysis demands and tools, yet are 
lacking data collection capabilities. In order to meet this demand, the OBP Series - USB 
version can act as an ActiveX server. This allows system integrators to integrate the system’s 
data capture capabilities with legacy analysis packages. 

 
This has been tested in LabVIEW 7.0 (National Instruments) as well as Visual Basic 6.0 
(Microsoft). In practice, these controls can be used in any environment that allows interaction 
with ActiveX servers (although it hasn’t been tested with tools other than those mentioned). 

 
 
 

9.2 Registration 
 

The ActiveX controls will be registered the first time that the OBP Series – USB version is run. 
 

 
 

      9.3 Examples 
 
Examples of LabVIEW VI, and a Visual Basic application are provided with the installation CD-
ROM. All examples assume a rudimentary knowledge of the respective development 
platforms. 

 
 
 

9.4 ActiveX Details  
 
Types 

1) usbUpdated 
a. Flag used to inform calling application if camera has made a new 

measurement (used with the DataUpdated property). Also used on startup to 
inform calling application that the camera has been initialized (used with the 
SettingsUpdated property) 

b. Values 
i. usbNotUpdated   = 0 (Settings/Data not yet updated) 
ii. usbUpdatedSusccessful  = 1 (Settings/Data have been 

updated) 
iii. usbFailed    = -1 (Failed to set up initial settings 

(e.g. setting gain on camera that doesn’t have gain control)) 
 
Events (in Visual Basic only) 
 
Note: Events can only be used in Visual Basic applications. In order to use events, the 
EventsEnabled property (described below) must be set to TRUE. 
 

1) DataUpdated:   OBP Series – USB version has made a new measurement 
 

2) ErrorMessage:   OBP Series – USB version is reporting an operational error (as a 
code and as a text message).  
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Properties 
 

1) NumUSBDevices 
a. Used to get number of the USB devices, connected to the USB ports. 

 
2) DetNamesTable 

a. Used to get table of the detector names. 
b. Default is set name of then first USB device . 
 

3) EnableEvents 
a. Used to enable Visual Basic events. This is compatible with Visual Basic 

applications that used simple broadcast events.  
b. Default is set to FALSE (no Visual Basic events). 
 

4) SettingsUpdated 
a. Used on startup to inform the calling application that the OBP Series – USB 

version has finished its initialization. 
b. Used with the usbUpdated type described above. 
 

5) DataUpdated 
a. Used by non-Visual Basic applications. 
b. Set to 0 by calling application to request new measurement from the OBP 

Series – USB version. 
c. Set to 1 by OBP Series – USB version to inform calling application that a new 

measurement has been made and processed. 
 

Methods 
 

1) GetData 
a. Return elements array for a set of  3 parameters: position X, position Y, and 

power P. 
b. Values position are in microns, power – in mW. 
 

2) HideForm 
a. Set SpotOn Analog USB application is hide. 
 

3) ShowForm 
a. Set SpotOn Analog USB application is show. 
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